Search Gradle plugins

Version 0.1.0-alpha2 (latest)

Created 02 September 2020.

Configure the project as Graal&Truffle language.

Using the plugins DSL:

plugins {
  id "org.graalvm.plugin.truffle-language" version "0.1.0-alpha2"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "org.graalvm.plugin:gradle-graal-truffle-plugins:0.1.0-alpha2"
  }
}

apply plugin: "org.graalvm.plugin.truffle-language"

Using the plugins DSL:

plugins {
  id("org.graalvm.plugin.truffle-language") version "0.1.0-alpha2"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("org.graalvm.plugin:gradle-graal-truffle-plugins:0.1.0-alpha2")
  }
}

apply(plugin = "org.graalvm.plugin.truffle-language")

Learn how to apply plugins to subprojects