Search Gradle plugins

Version 1.2.0-dev6

1.2.0-dev6

Created 13 January 2020.

The test cartridge plugin applies all basic configurations and tasks of an integration test cartridge.

Using the plugins DSL:

plugins {
  id("com.intershop.gradle.icm.cartridge.test") version "1.2.0-dev6"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("com.intershop.gradle.icm:icm-gradle-plugin:1.2.0-dev6")
  }
}

apply(plugin = "com.intershop.gradle.icm.cartridge.test")

Using the plugins DSL:

plugins {
  id "com.intershop.gradle.icm.cartridge.test" version "1.2.0-dev6"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "com.intershop.gradle.icm:icm-gradle-plugin:1.2.0-dev6"
  }
}

apply plugin: "com.intershop.gradle.icm.cartridge.test"

Learn how to apply plugins to subprojects