Search Gradle plugins

Version 4.1.1

Created 04 October 2018.

ml-development-tools plugin for developing data services on MarkLogic

Using the plugins DSL:

plugins {
  id "com.marklogic.ml-development-tools" version "4.1.1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "com.marklogic:ml-development-tools:4.1.1"
  }
}

apply plugin: "com.marklogic.ml-development-tools"

Using the plugins DSL:

plugins {
  id("com.marklogic.ml-development-tools") version "4.1.1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("com.marklogic:ml-development-tools:4.1.1")
  }
}

apply(plugin = "com.marklogic.ml-development-tools")

Learn how to apply plugins to subprojects