Search Gradle plugins

Version 0.1

Created 19 December 2017.

jOOQ plugin aimed for use with kotlin-dsl gradle projects

Using the plugins DSL:

plugins {
  id "com.rohanprabhu.kotlin-dsl-jooq" version "0.1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "gradle.plugin.com.rohanprabhu:kotlin-dsl-jooq-plugin:0.1"
  }
}

apply plugin: "com.rohanprabhu.kotlin-dsl-jooq"

Using the plugins DSL:

plugins {
  id("com.rohanprabhu.kotlin-dsl-jooq") version "0.1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("gradle.plugin.com.rohanprabhu:kotlin-dsl-jooq-plugin:0.1")
  }
}

apply(plugin = "com.rohanprabhu.kotlin-dsl-jooq")

Learn how to apply plugins to subprojects