Search Gradle plugins

enterprise.groovy.plugin

The Enterprise Groovy Plugin provides static compilation by default, and optional enforcement.

https://virtualdogbert.github.io/enterprise-groovy-plugin/

Version 1.0.RC4

Created 17 February 2019.

The Enterprise Groovy Plugin provides static compilation by default, and optional enforcement.

Using the plugins DSL:

plugins {
  id "enterprise.groovy.plugin" version "1.0.RC4"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "com.virtualdogbert:enterprise-groovy-plugin:1.0.RC4"
  }
}

apply plugin: "enterprise.groovy.plugin"

Using the plugins DSL:

plugins {
  id("enterprise.groovy.plugin") version "1.0.RC4"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("com.virtualdogbert:enterprise-groovy-plugin:1.0.RC4")
  }
}

apply(plugin = "enterprise.groovy.plugin")

Learn how to apply plugins to subprojects