Search Gradle plugins

nebula.dependency-lock

A plugin to allow people using dynamic dependency versions to lock them to specific versions.

https://github.com/nebula-plugins/gradle-dependency-lock-plugin

Using the plugins DSL:

plugins {
  id "nebula.dependency-lock" version "5.0.2"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "com.netflix.nebula:gradle-dependency-lock-plugin:5.0.2"
  }
}

apply plugin: "nebula.dependency-lock"

Using the plugins DSL:

plugins {
  id("nebula.dependency-lock") version "5.0.2"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("com.netflix.nebula:gradle-dependency-lock-plugin:5.0.2")
  }
}

apply(plugin = "nebula.dependency-lock")

Learn how to apply plugins to subprojects