Search Gradle plugins

Version 1.0.35 (latest)

Created 05 March 2019.

Gradle plugin to build a project against multiple versions of scala

Using the plugins DSL:

plugins {
  id "com.adtran.scala-multiversion-plugin" version "1.0.35"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "com.adtran:scala-multiversion-plugin:1.0.35"
  }
}

apply plugin: "com.adtran.scala-multiversion-plugin"

Using the plugins DSL:

plugins {
  id("com.adtran.scala-multiversion-plugin") version "1.0.35"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("com.adtran:scala-multiversion-plugin:1.0.35")
  }
}

apply(plugin = "com.adtran.scala-multiversion-plugin")

Learn how to apply plugins to subprojects