Search Gradle plugins

Version 0.4.0 (latest)

Created 24 July 2015.

Plugin for using Guice dependency injection in plugin development

Using the plugins DSL:

plugins {
  id "com.chrisgahlert.gradle-guice-plugin" version "0.4.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "gradle.plugin.com.chrisgahlert:gradle-guice-plugin:0.4.0"
  }
}

apply plugin: "com.chrisgahlert.gradle-guice-plugin"

Using the plugins DSL:

plugins {
  id("com.chrisgahlert.gradle-guice-plugin") version "0.4.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("gradle.plugin.com.chrisgahlert:gradle-guice-plugin:0.4.0")
  }
}

apply(plugin = "com.chrisgahlert.gradle-guice-plugin")

Learn how to apply plugins to subprojects