Search Gradle plugins

Version 0.0.2 (latest)

Created 19 September 2017.

Common defaults for Java projects

Using the plugins DSL:

plugins {
  id "com.devtub.scramble.java-defaults" version "0.0.2"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "gradle.plugin.gradle.plugin.com.devtub.scramble:java-defaults-gradle-plugin:0.0.2"
  }
}

apply plugin: "com.devtub.scramble.java-defaults"

Using the plugins DSL:

plugins {
  id("com.devtub.scramble.java-defaults") version "0.0.2"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("gradle.plugin.gradle.plugin.com.devtub.scramble:java-defaults-gradle-plugin:0.0.2")
  }
}

apply(plugin = "com.devtub.scramble.java-defaults")

Learn how to apply plugins to subprojects