Search Gradle plugins

com.digitalascent.gradle.errorprone

Applies default Google Error Prone configuration to all JavaCompile tasks

https://github.com/cslee00/digitalascent-gradle-errorprone

Version 1.0 (latest)

Created 29 April 2018.

Applies default Google Error Prone configuration to all JavaCompile tasks

Using the plugins DSL:

plugins {
  id "com.digitalascent.gradle.errorprone" version "1.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "gradle.plugin.com.digitalascent:digitalascent-gradle-errorprone:1.0"
  }
}

apply plugin: "com.digitalascent.gradle.errorprone"

Using the plugins DSL:

plugins {
  id("com.digitalascent.gradle.errorprone") version "1.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("gradle.plugin.com.digitalascent:digitalascent-gradle-errorprone:1.0")
  }
}

apply(plugin = "com.digitalascent.gradle.errorprone")

Learn how to apply plugins to subprojects