Search Gradle plugins

Version 1.2.1 (latest)

Created 02 July 2022.

Allows to import boms as version catalogs

Using the plugins DSL:

plugins {
  id "com.faendir.gradle.bom-version-catalog" version "1.2.1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "com.faendir.gradle:bom-version-catalog:1.2.1"
  }
}

apply plugin: "com.faendir.gradle.bom-version-catalog"

Using the plugins DSL:

plugins {
  id("com.faendir.gradle.bom-version-catalog") version "1.2.1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("com.faendir.gradle:bom-version-catalog:1.2.1")
  }
}

apply(plugin = "com.faendir.gradle.bom-version-catalog")

Learn how to apply plugins to subprojects