Search Gradle plugins

Version 1.2.0 (latest)

Created 04 March 2019.

Detects use of legacy APIs which modern Java versions supersede.

Using the plugins DSL:

plugins {
  id "com.github.andygoossens.gradle-modernizer-plugin" version "1.2.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "gradle.plugin.com.github.andygoossens:gradle-modernizer-plugin:1.2.0"
  }
}

apply plugin: "com.github.andygoossens.gradle-modernizer-plugin"

Using the plugins DSL:

plugins {
  id("com.github.andygoossens.gradle-modernizer-plugin") version "1.2.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("gradle.plugin.com.github.andygoossens:gradle-modernizer-plugin:1.2.0")
  }
}

apply(plugin = "com.github.andygoossens.gradle-modernizer-plugin")

Learn how to apply plugins to subprojects