Search Gradle plugins

Version 0.0.3 (latest)

Created 25 February 2020.

A legacy osgi plugin in Gradle 5

Using the plugins DSL:

plugins {
  id "com.github.blindpirate.osgi" version "0.0.3"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "gradle.plugin.com.github.blindpirate:gradle-legacy-osgi-plugin:0.0.3"
  }
}

apply plugin: "com.github.blindpirate.osgi"

Using the plugins DSL:

plugins {
  id("com.github.blindpirate.osgi") version "0.0.3"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("gradle.plugin.com.github.blindpirate:gradle-legacy-osgi-plugin:0.0.3")
  }
}

apply(plugin = "com.github.blindpirate.osgi")

Learn how to apply plugins to subprojects