Search Gradle plugins

Version 1.4 (latest)

Created 23 May 2017.

Multi-dimensional environment handling for Gradle

Using the plugins DSL:

plugins {
  id "com.github.lferenczi.env" version "1.4"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "gradle.plugin.com.github.lferenczi.gradle:gradle-env-plugin:1.4"
  }
}

apply plugin: "com.github.lferenczi.env"

Using the plugins DSL:

plugins {
  id("com.github.lferenczi.env") version "1.4"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("gradle.plugin.com.github.lferenczi.gradle:gradle-env-plugin:1.4")
  }
}

apply(plugin = "com.github.lferenczi.env")

Learn how to apply plugins to subprojects