Search Gradle plugins

Version 0.4.0 (latest)

Created 10 April 2021.

A plugin that can updating the semantic versions like `yarn version` command.

Using the plugins DSL:

plugins {
  id "com.github.rising3.semver" version "0.4.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "com.github.rising3:semver-gradle-plugin:0.4.0"
  }
}

apply plugin: "com.github.rising3.semver"

Using the plugins DSL:

plugins {
  id("com.github.rising3.semver") version "0.4.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("com.github.rising3:semver-gradle-plugin:0.4.0")
  }
}

apply(plugin = "com.github.rising3.semver")

Learn how to apply plugins to subprojects