Search Gradle plugins

Version 2.1 (latest)

Created 08 June 2021.

Raise the practicality of 'gradle-dsl' to a new level.

Using the plugins DSL:

plugins {
  id "com.meowool.toolkit.gradle-dsl-x-core" version "2.1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "com.meowool.toolkit:gradle-dsl-x-core:2.1"
  }
}

apply plugin: "com.meowool.toolkit.gradle-dsl-x-core"

Using the plugins DSL:

plugins {
  id("com.meowool.toolkit.gradle-dsl-x-core") version "2.1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("com.meowool.toolkit:gradle-dsl-x-core:2.1")
  }
}

apply(plugin = "com.meowool.toolkit.gradle-dsl-x-core")

Learn how to apply plugins to subprojects