Search Gradle plugins

Version 1.2.10 (latest)

Created 30 April 2019.

Gradle plugin to support version handling

Using the plugins DSL:

plugins {
  id "com.namics.oss.gradle.version-support-plugin" version "1.2.10"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "com.namics.oss.gradle.version:version-support-plugin:1.2.10"
  }
}

apply plugin: "com.namics.oss.gradle.version-support-plugin"

Using the plugins DSL:

plugins {
  id("com.namics.oss.gradle.version-support-plugin") version "1.2.10"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("com.namics.oss.gradle.version:version-support-plugin:1.2.10")
  }
}

apply(plugin = "com.namics.oss.gradle.version-support-plugin")

Learn how to apply plugins to subprojects