Search Gradle plugins

com.sharp.applyfrom

Due to the limitation of gradle apply from limitation, apply from https endpoint can not using authentication. so using this plugin can apply from a gradle script file from dependencies.

https://github.com/xiaoweialien/gradle-applyfrom-plugin

Version 1.0.2 (latest)

Created 01 May 2020.

Due to the limitation of gradle apply from limitation, apply from https endpoint can not using authentication. so using this plugin can apply from a gradle script file from dependencies.

Using the plugins DSL:

plugins {
  id "com.sharp.applyfrom" version "1.0.2"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "gradle.plugin.com.sharp.gradle:gradle-applyfrom-plugin:1.0.2"
  }
}

apply plugin: "com.sharp.applyfrom"

Using the plugins DSL:

plugins {
  id("com.sharp.applyfrom") version "1.0.2"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("gradle.plugin.com.sharp.gradle:gradle-applyfrom-plugin:1.0.2")
  }
}

apply(plugin = "com.sharp.applyfrom")

Learn how to apply plugins to subprojects