Search Gradle plugins

Version 0.3 (latest)

Created 22 April 2021.

Supports the development of plugins for MagicDraw

Using the plugins DSL:

plugins {
  id "de.lukaskoerfer.gradle.magicdraw" version "0.3"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "de.lukaskoerfer.gradle:magicdraw:0.3"
  }
}

apply plugin: "de.lukaskoerfer.gradle.magicdraw"

Using the plugins DSL:

plugins {
  id("de.lukaskoerfer.gradle.magicdraw") version "0.3"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("de.lukaskoerfer.gradle:magicdraw:0.3")
  }
}

apply(plugin = "de.lukaskoerfer.gradle.magicdraw")

Learn how to apply plugins to subprojects