Search Gradle plugins

Version 0.4.13 (latest)

Created 21 November 2017.

Resolves dependencies from MANIFEST.MF files

Using the plugins DSL:

plugins {
  id "de.monkeyworks.buildmonkey.ManifestDependencyPlugin" version "0.4.13"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "de.monkeyworks.buildmonkey:gradle.dependency:0.4.13"
  }
}

apply plugin: "de.monkeyworks.buildmonkey.ManifestDependencyPlugin"

Using the plugins DSL:

plugins {
  id("de.monkeyworks.buildmonkey.ManifestDependencyPlugin") version "0.4.13"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("de.monkeyworks.buildmonkey:gradle.dependency:0.4.13")
  }
}

apply(plugin = "de.monkeyworks.buildmonkey.ManifestDependencyPlugin")

Learn how to apply plugins to subprojects