Search Gradle plugins

Version 3.0.1

Created 21 April 2022.

Common conventions for all MythicDrops Kotlin JVM Gradle projects.

Using the plugins DSL:

plugins {
  id "dev.mythicdrops.gradle.convention.kotlin.jvm" version "3.0.1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "dev.mythicdrops:mythicdrops-gradle-plugin:3.0.1"
  }
}

apply plugin: "dev.mythicdrops.gradle.convention.kotlin.jvm"

Using the plugins DSL:

plugins {
  id("dev.mythicdrops.gradle.convention.kotlin.jvm") version "3.0.1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("dev.mythicdrops:mythicdrops-gradle-plugin:3.0.1")
  }
}

apply(plugin = "dev.mythicdrops.gradle.convention.kotlin.jvm")

Learn how to apply plugins to subprojects