Search Gradle plugins

Version 1.3.0 (latest)

Created 21 November 2022.

Binary Compatibility Plugin

Using the plugins DSL:

plugins {
  id "gov.raptor.gradle.plugins.binary-compatibility" version "1.3.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "gov.raptor.gradle.plugins:BinaryCompatibilityPlugin:1.3.0"
  }
}

apply plugin: "gov.raptor.gradle.plugins.binary-compatibility"

Using the plugins DSL:

plugins {
  id("gov.raptor.gradle.plugins.binary-compatibility") version "1.3.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("gov.raptor.gradle.plugins:BinaryCompatibilityPlugin:1.3.0")
  }
}

apply(plugin = "gov.raptor.gradle.plugins.binary-compatibility")

Learn how to apply plugins to subprojects