Search Gradle plugins

io.github.ezequielb.gradle-dependency-enforcer

Gradle plugin to enforce dependencies in a finer way within a project artifact

https://github.com/EzequielB/gradle-dependency-enforcer

Version 1.0.1 (latest)

Created 30 May 2016.

Gradle plugin to enforce dependencies in a finer way within a project artifact

Using the plugins DSL:

plugins {
  id "io.github.ezequielb.gradle-dependency-enforcer" version "1.0.1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "io.github.ezequielb:gradle-dependency-enforcer:1.0.1"
  }
}

apply plugin: "io.github.ezequielb.gradle-dependency-enforcer"

Using the plugins DSL:

plugins {
  id("io.github.ezequielb.gradle-dependency-enforcer") version "1.0.1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("io.github.ezequielb:gradle-dependency-enforcer:1.0.1")
  }
}

apply(plugin = "io.github.ezequielb.gradle-dependency-enforcer")

Learn how to apply plugins to subprojects