Search Gradle plugins

io.redskap.swagger-brake

A plugin to check Swagger definition files for any breaking API changes

http://redskap.io

Version 0.3.0 (latest)

Created 31 March 2019.

A plugin to check Swagger definition files for any breaking API changes

Using the plugins DSL:

plugins {
  id "io.redskap.swagger-brake" version "0.3.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "io.redskap:swagger-brake-gradle:0.3.0"
  }
}

apply plugin: "io.redskap.swagger-brake"

Using the plugins DSL:

plugins {
  id("io.redskap.swagger-brake") version "0.3.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("io.redskap:swagger-brake-gradle:0.3.0")
  }
}

apply(plugin = "io.redskap.swagger-brake")

Learn how to apply plugins to subprojects