Search Gradle plugins

Version 18.1.0 (latest)

Created 19 November 2021.

Verifies that ivy descriptor does not contain unspecified as version for dependencies

Using the plugins DSL:

plugins {
  id "nebula.ivy-verify-unspecified-version-dependencies" version "18.1.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "com.netflix.nebula:nebula-publishing-plugin:18.1.0"
  }
}

apply plugin: "nebula.ivy-verify-unspecified-version-dependencies"

Using the plugins DSL:

plugins {
  id("nebula.ivy-verify-unspecified-version-dependencies") version "18.1.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("com.netflix.nebula:nebula-publishing-plugin:18.1.0")
  }
}

apply(plugin = "nebula.ivy-verify-unspecified-version-dependencies")

Learn how to apply plugins to subprojects