Search Gradle plugins

Version 1.3.1 (latest)

Created 03 February 2021.

Reasonable settings for Bintray publishing

Using the plugins DSL:

plugins {
  id "net.kyori.indra.publishing.bintray" version "1.3.1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "net.kyori:indra-publishing-bintray:1.3.1"
  }
}

apply plugin: "net.kyori.indra.publishing.bintray"

Using the plugins DSL:

plugins {
  id("net.kyori.indra.publishing.bintray") version "1.3.1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("net.kyori:indra-publishing-bintray:1.3.1")
  }
}

apply(plugin = "net.kyori.indra.publishing.bintray")

Learn how to apply plugins to subprojects