Search Gradle plugins

Version 0.6.1 (latest)

Created 04 January 2019.

Gradle plugin to use the error-prone compiler for Java

Using the plugins DSL:

plugins {
  id "net.ltgt.errorprone-base" version "0.6.1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "net.ltgt.gradle:gradle-errorprone-plugin:0.6.1"
  }
}

apply plugin: "net.ltgt.errorprone-base"

Using the plugins DSL:

plugins {
  id("net.ltgt.errorprone-base") version "0.6.1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("net.ltgt.gradle:gradle-errorprone-plugin:0.6.1")
  }
}

apply(plugin = "net.ltgt.errorprone-base")

Learn how to apply plugins to subprojects