Search Gradle plugins

Version 0.6.0 (latest)

Created 28 November 2022.

Conventions when the Snyk plugin is applied on a Java project

Using the plugins DSL:

plugins {
  id "net.wooga.snyk-wdk-java" version "0.6.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "net.wooga.snyk:snyk-wdk-java:0.6.0"
  }
}

apply plugin: "net.wooga.snyk-wdk-java"

Using the plugins DSL:

plugins {
  id("net.wooga.snyk-wdk-java") version "0.6.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("net.wooga.snyk:snyk-wdk-java:0.6.0")
  }
}

apply(plugin = "net.wooga.snyk-wdk-java")

Learn how to apply plugins to subprojects