Search Gradle plugins

Version 0.0.0 (latest)

Created 12 May 2020.

a plugin to run scala mima on your library to check backwards compatibility

Using the plugins DSL:

plugins {
  id "org.github.borissmidt.gradle-mima-plugin" version "0.0.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "org.github.borissmidt:mima-gradle-plugin:0.0.0"
  }
}

apply plugin: "org.github.borissmidt.gradle-mima-plugin"

Using the plugins DSL:

plugins {
  id("org.github.borissmidt.gradle-mima-plugin") version "0.0.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("org.github.borissmidt:mima-gradle-plugin:0.0.0")
  }
}

apply(plugin = "org.github.borissmidt.gradle-mima-plugin")

Learn how to apply plugins to subprojects