Search Gradle plugins

pl.mareklangiewicz.deps.settings

Updated dependencies for typical java/kotlin/android projects (with IDE support).

https://github.com/langara/deps.kt

Version 0.2.08 (latest)

Created 28 April 2021.

Updated dependencies for typical java/kotlin/android projects (with IDE support).

Using the plugins DSL:

plugins {
  id "pl.mareklangiewicz.deps.settings" version "0.2.08"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "pl.mareklangiewicz.deps:deps:0.2.08"
  }
}

apply plugin: "pl.mareklangiewicz.deps.settings"

Using the plugins DSL:

plugins {
  id("pl.mareklangiewicz.deps.settings") version "0.2.08"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("pl.mareklangiewicz.deps:deps:0.2.08")
  }
}

apply(plugin = "pl.mareklangiewicz.deps.settings")

Learn how to apply plugins to subprojects