Search Gradle plugins

Version 1.0 (latest)

Created 28 April 2015.

Gradle plugin for Classycle dependency analyzer

Using the plugins DSL:

plugins {
  id "pl.squirrel.classycle-gradle" version "1.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "gradle.plugin.pl.squirrel:classycle-gradle-plugin:1.0"
  }
}

apply plugin: "pl.squirrel.classycle-gradle"

Using the plugins DSL:

plugins {
  id("pl.squirrel.classycle-gradle") version "1.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("gradle.plugin.pl.squirrel:classycle-gradle-plugin:1.0")
  }
}

apply(plugin = "pl.squirrel.classycle-gradle")

Learn how to apply plugins to subprojects