Search Gradle plugins

ru.kontur.kinfra.presets

Default configuration for Gradle projects used in Kontur

https://github.com/kinfra/gradle-presets

Version 1.5 (latest)

Created 10 June 2021.

Default configuration for Gradle projects used in Kontur

Using the plugins DSL:

plugins {
  id "ru.kontur.kinfra.presets" version "1.5"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "ru.kontur.kinfra:kinfra-gradle-presets:1.5"
  }
}

apply plugin: "ru.kontur.kinfra.presets"

Using the plugins DSL:

plugins {
  id("ru.kontur.kinfra.presets") version "1.5"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("ru.kontur.kinfra:kinfra-gradle-presets:1.5")
  }
}

apply(plugin = "ru.kontur.kinfra.presets")

Learn how to apply plugins to subprojects