Search Gradle plugins

Version 1.0.0-beta.2

Created 01 March 2022.

SonarLint static code analysis using stand-alone SonarLint engine, for Java and Node projects. Min Gradle version 7.0.

Using the plugins DSL:

plugins {
  id "se.solrike.sonarlint" version "1.0.0-beta.2"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "se.solrike.sonarlint:sonarlint-gradle-plugin:1.0.0-beta.2"
  }
}

apply plugin: "se.solrike.sonarlint"

Using the plugins DSL:

plugins {
  id("se.solrike.sonarlint") version "1.0.0-beta.2"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("se.solrike.sonarlint:sonarlint-gradle-plugin:1.0.0-beta.2")
  }
}

apply(plugin = "se.solrike.sonarlint")

Learn how to apply plugins to subprojects