Search Gradle plugins

Version 0.3 (latest)

Created 26 July 2017.

Plugin to enforce standard defaults

Using the plugins DSL:

plugins {
  id "systems.concurrent.apply-defaults-plugin" version "0.3"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "gradle.plugin.systems.concurrent.apply-defaults-plugin:apply-defaults-plugin:0.3"
  }
}

apply plugin: "systems.concurrent.apply-defaults-plugin"

Using the plugins DSL:

plugins {
  id("systems.concurrent.apply-defaults-plugin") version "0.3"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("gradle.plugin.systems.concurrent.apply-defaults-plugin:apply-defaults-plugin:0.3")
  }
}

apply(plugin = "systems.concurrent.apply-defaults-plugin")

Learn how to apply plugins to subprojects