Search Gradle plugins

Version 0.16 (latest)

Created 09 March 2020.

Yet another WsImport Gradle plugin - requires Java 11 and Gradle 5.6 or greater. If you're using an earlier version of Java or Gradle use 0.10. If you're still on Gradle 3.x use version 0.3 of this plugin.

Using the plugins DSL:

plugins {
  id "uk.co.boothen.gradle.wsimport" version "0.16"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "gradle.plugin.uk.co.boothen.gradle:gradle-wsimport:0.16"
  }
}

apply plugin: "uk.co.boothen.gradle.wsimport"

Using the plugins DSL:

plugins {
  id("uk.co.boothen.gradle.wsimport") version "0.16"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("gradle.plugin.uk.co.boothen.gradle:gradle-wsimport:0.16")
  }
}

apply(plugin = "uk.co.boothen.gradle.wsimport")

Learn how to apply plugins to subprojects