Search Gradle plugins

Version 5.0.0 (latest)

Created 15 May 2021.

Polyglot Version Catalogs

Using the plugins DSL:

plugins {
  id "ca.stellardrift.polyglot-version-catalogs" version "5.0.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "ca.stellardrift:gradle-plugin-configurate:5.0.0"
  }
}

apply plugin: "ca.stellardrift.polyglot-version-catalogs"

Using the plugins DSL:

plugins {
  id("ca.stellardrift.polyglot-version-catalogs") version "5.0.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("ca.stellardrift:gradle-plugin-configurate:5.0.0")
  }
}

apply(plugin = "ca.stellardrift.polyglot-version-catalogs")

Learn how to apply plugins to subprojects