Search Gradle plugins

com.github.snowdream.gradle.java-version-check

a gradle plugin to avoid the error: "java.lang.UnsupportedClassVersionError: Unsupported major.minor version **"

https://github.com/snowdream/java-version-check

Version 0.1 (latest)

Created 03 October 2016.

a gradle plugin to avoid the error: "java.lang.UnsupportedClassVersionError: Unsupported major.minor version **"

Using the plugins DSL:

plugins {
  id "com.github.snowdream.gradle.java-version-check" version "0.1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "gradle.plugin.com.github.snowdream.gradle:java-version-check:0.1"
  }
}

apply plugin: "com.github.snowdream.gradle.java-version-check"

Using the plugins DSL:

plugins {
  id("com.github.snowdream.gradle.java-version-check") version "0.1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("gradle.plugin.com.github.snowdream.gradle:java-version-check:0.1")
  }
}

apply(plugin = "com.github.snowdream.gradle.java-version-check")

Learn how to apply plugins to subprojects