Search Gradle plugins

Version 0.8.1 (latest)

Created 31 May 2022.

The right prescription for your gradle build.

Using the plugins DSL:

plugins {
  id "com.osacky.doctor" version "0.8.1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "com.osacky.doctor:doctor-plugin:0.8.1"
  }
}

apply plugin: "com.osacky.doctor"

Using the plugins DSL:

plugins {
  id("com.osacky.doctor") version "0.8.1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("com.osacky.doctor:doctor-plugin:0.8.1")
  }
}

apply(plugin = "com.osacky.doctor")

Learn how to apply plugins to subprojects