Search Gradle plugins

com.palantir.revapi

API/ABI backwards compatibility for Java libraries using Revapi

https://github.com/palantir/gradle-revapi

Version 1.4.4 (latest)

Created 26 November 2020.

API/ABI backwards compatibility for Java libraries using Revapi

Using the plugins DSL:

plugins {
  id "com.palantir.revapi" version "1.4.4"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "com.palantir.gradle.revapi:gradle-revapi:1.4.4"
  }
}

apply plugin: "com.palantir.revapi"

Using the plugins DSL:

plugins {
  id("com.palantir.revapi") version "1.4.4"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("com.palantir.gradle.revapi:gradle-revapi:1.4.4")
  }
}

apply(plugin = "com.palantir.revapi")

Learn how to apply plugins to subprojects