Search Gradle plugins

Version 2.1.0-1 (latest)

Created 09 June 2020.

Detects use of legacy APIs which modern Java versions supersede

Using the plugins DSL:

plugins {
  id "com.simonharrer.modernizer" version "2.1.0-1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "gradle.plugin.com.simonharrer:gradle-modernizer-plugin:2.1.0-1"
  }
}

apply plugin: "com.simonharrer.modernizer"

Using the plugins DSL:

plugins {
  id("com.simonharrer.modernizer") version "2.1.0-1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("gradle.plugin.com.simonharrer:gradle-modernizer-plugin:2.1.0-1")
  }
}

apply(plugin = "com.simonharrer.modernizer")

Learn how to apply plugins to subprojects