Search Gradle plugins

edu.wpi.first.wpilib.versioning.WPILibVersioningPlugin

This plugin provides maven remote settings and versioning for the WPILib Suite FRC projects.

https://github.com/wpilibsuite/wpilib-version-plugin

Version 2.4 (latest)

Created 05 January 2019.

This plugin provides maven remote settings and versioning for the WPILib Suite FRC projects.

Using the plugins DSL:

plugins {
  id "edu.wpi.first.wpilib.versioning.WPILibVersioningPlugin" version "2.4"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "edu.wpi.first.wpilib.versioning:wpilib-version-plugin:2.4"
  }
}

apply plugin: "edu.wpi.first.wpilib.versioning.WPILibVersioningPlugin"

Using the plugins DSL:

plugins {
  id("edu.wpi.first.wpilib.versioning.WPILibVersioningPlugin") version "2.4"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("edu.wpi.first.wpilib.versioning:wpilib-version-plugin:2.4")
  }
}

apply(plugin = "edu.wpi.first.wpilib.versioning.WPILibVersioningPlugin")

Learn how to apply plugins to subprojects