Search Gradle plugins

Version 0.6

Created 01 September 2015.

Jacoco Git diff code coverage

Using the plugins DSL:

plugins {
  id "gradle.jacoco.gitDiff" version "0.6"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "gradle.plugin.gradle.jacoco:jacoco-diff-coverage:0.6"
  }
}

apply plugin: "gradle.jacoco.gitDiff"

Using the plugins DSL:

plugins {
  id("gradle.jacoco.gitDiff") version "0.6"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("gradle.plugin.gradle.jacoco:jacoco-diff-coverage:0.6")
  }
}

apply(plugin = "gradle.jacoco.gitDiff")

Learn how to apply plugins to subprojects