Search Gradle plugins

Version 0.8.9 (latest)

Created 01 December 2022.

Configure Swagger API Generation

Using the plugins DSL:

plugins {
  id "io.cloudflight.autoconfigure.swagger-api-configure" version "0.8.9"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "io.cloudflight.gradle:autoconfigure:0.8.9"
  }
}

apply plugin: "io.cloudflight.autoconfigure.swagger-api-configure"

Using the plugins DSL:

plugins {
  id("io.cloudflight.autoconfigure.swagger-api-configure") version "0.8.9"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("io.cloudflight.gradle:autoconfigure:0.8.9")
  }
}

apply(plugin = "io.cloudflight.autoconfigure.swagger-api-configure")

Learn how to apply plugins to subprojects