Search Gradle plugins

Version 3.0.0-rc.7

Created 19 December 2018.

Verify that your generated POM's fullfill the requirements for maven central

Using the plugins DSL:

plugins {
  id "io.freefair.maven-central.validate-poms" version "3.0.0-rc.7"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "io.freefair.gradle:maven-plugin:3.0.0-rc.7"
  }
}

apply plugin: "io.freefair.maven-central.validate-poms"

Using the plugins DSL:

plugins {
  id("io.freefair.maven-central.validate-poms") version "3.0.0-rc.7"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("io.freefair.gradle:maven-plugin:3.0.0-rc.7")
  }
}

apply(plugin = "io.freefair.maven-central.validate-poms")

Learn how to apply plugins to subprojects