Search Gradle plugins

io.freefair.maven-central.validate-poms

Verify that your generated POM's fullfill the requirements for maven central

https://docs.freefair.io/gradle-plugins/4.1.0/reference/

Using the plugins DSL:

plugins {
  id "io.freefair.maven-central.validate-poms" version "3.4.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "io.freefair.gradle:maven-plugin:3.4.0"
  }
}

apply plugin: "io.freefair.maven-central.validate-poms"

Using the plugins DSL:

plugins {
  id("io.freefair.maven-central.validate-poms") version "3.4.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("io.freefair.gradle:maven-plugin:3.4.0")
  }
}

apply(plugin = "io.freefair.maven-central.validate-poms")

Learn how to apply plugins to subprojects