Search Gradle plugins

Version 0.0.2 (latest)

Created 07 June 2022.

A plugin to start/stop embedded kafka

Using the plugins DSL:

plugins {
  id "io.github.ashishkujoy.embeddedKafka" version "0.0.2"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "io.github.ashishkujoy.embeddedKafka:gradle-embedded-kafka-plugin:0.0.2"
  }
}

apply plugin: "io.github.ashishkujoy.embeddedKafka"

Using the plugins DSL:

plugins {
  id("io.github.ashishkujoy.embeddedKafka") version "0.0.2"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("io.github.ashishkujoy.embeddedKafka:gradle-embedded-kafka-plugin:0.0.2")
  }
}

apply(plugin = "io.github.ashishkujoy.embeddedKafka")

Learn how to apply plugins to subprojects