Search Gradle plugins

io.heapy.gradle.kotlin.repositories

Plugin that adds necessary kotlin (eap/dev) repositories depends on requested kotlin version.

https://github.com/Heapy/heapy-kotlin-repositories-gradle-plugin

Version 1.1.0 (latest)

Created 06 January 2021.

Plugin that adds necessary kotlin (eap/dev) repositories depends on requested kotlin version.

Using the plugins DSL:

plugins {
  id "io.heapy.gradle.kotlin.repositories" version "1.1.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "io.heapy.gradle.kotlin.repositories:heapy-kotlin-repositories-gradle-plugin:1.1.0"
  }
}

apply plugin: "io.heapy.gradle.kotlin.repositories"

Using the plugins DSL:

plugins {
  id("io.heapy.gradle.kotlin.repositories") version "1.1.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("io.heapy.gradle.kotlin.repositories:heapy-kotlin-repositories-gradle-plugin:1.1.0")
  }
}

apply(plugin = "io.heapy.gradle.kotlin.repositories")

Learn how to apply plugins to subprojects