Search Gradle plugins

nebula.gradle-dependency-lock

A plugin to allow people using dynamic dependency versions to lock them to specific versions.

https://github.com/nebula-plugins/gradle-dependency-lock-plugin

Version 2.2.4 (latest)

Created 29 October 2015.

No version description available.

Using the plugins DSL:

plugins {
  id "nebula.gradle-dependency-lock" version "2.2.4"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "com.netflix.nebula:gradle-dependency-lock-plugin:2.2.4"
  }
}

apply plugin: "nebula.gradle-dependency-lock"

Using the plugins DSL:

plugins {
  id("nebula.gradle-dependency-lock") version "2.2.4"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("com.netflix.nebula:gradle-dependency-lock-plugin:2.2.4")
  }
}

apply(plugin = "nebula.gradle-dependency-lock")

Learn how to apply plugins to subprojects