Search Gradle plugins

Version 0.1.3

Created 14 January 2016.

Gosu language compiler for Gradle. Built with Gradle 2.9.

This has also been tested extensively with Gradle version(s): 2.8, 2.10
Less rigorous testing was also done against versions: 2.3-rc-3, 2.3, 2.4
Due to Gradle API changes, the plugin is incompatible with versions: 2.5, 2.6, 2.7

Projects applying this plugin require a compile-time dependency on the gosu-core-api library. Please include this in the depencencies closure:

dependencies {
compile group: 'org.gosu-lang.gosu', name: 'gosu-core-api', version: '1.10'
}

Using the plugins DSL:

plugins {
  id "org.gosu-lang.gosu" version "0.1.3"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "gradle.plugin.org.gosu-lang.gosu:gradle-gosu-plugin:0.1.3"
  }
}

apply plugin: "org.gosu-lang.gosu"

Using the plugins DSL:

plugins {
  id("org.gosu-lang.gosu") version "0.1.3"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("gradle.plugin.org.gosu-lang.gosu:gradle-gosu-plugin:0.1.3")
  }
}

apply(plugin = "org.gosu-lang.gosu")

Learn how to apply plugins to subprojects