Search Gradle plugins

org.gosu-lang.gosu

Gosu language compiler for Gradle

http://gosu-lang.org

Version 0.3.10 (latest)

Created 30 May 2018.

Gosu language compiler for Gradle. Built with Gradle 4.7.

This has also been tested extensively with Gradle version(s): 2.12, 2.13, 2.14.1, 3.0, 3.1, 3.2.1, 3.3, 3.4.1, 3.5, 4.1, 4.2.1, 4.3.1, 4.4.1, 4.5.1, 4.6, 4.8-rc-2

** Gradle versions below 2.12 are no longer supported **

Projects applying this plugin require a compile-time dependency on the gosu-core-api library.

This version requires Gosu 1.13.9 or greater, or 1.14.2 or greater.

Please include this in the depencencies closure:

dependencies {
compile group: 'org.gosu-lang.gosu', name: 'gosu-core-api', version: '1.14.9'
}

Using the plugins DSL:

plugins {
  id "org.gosu-lang.gosu" version "0.3.10"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "gradle.plugin.org.gosu-lang.gosu:gradle-gosu-plugin:0.3.10"
  }
}

apply plugin: "org.gosu-lang.gosu"

Using the plugins DSL:

plugins {
  id("org.gosu-lang.gosu") version "0.3.10"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("gradle.plugin.org.gosu-lang.gosu:gradle-gosu-plugin:0.3.10")
  }
}

apply(plugin = "org.gosu-lang.gosu")

Learn how to apply plugins to subprojects